Malfunctioning after upgraded

Bugs and glitches found in using MicroCity

Malfunctioning after upgraded

Postby suheti » Fri Nov 12, 2010 9:56 pm

Hi Dr Sun

I've just upgraded from MicroCity 1.009 to 1.01. The demo codes for Discrete Event Simulation built in the SciTE cannot run normally under the new version of Microcity and leads to crush of the software.

Xuehe
suheti
 
Posts: 3
Joined: Fri Nov 12, 2010 9:12 pm

Re: Malfunctioning after upgraded

Postby suheti » Fri Nov 12, 2010 10:05 pm

Another problem spotted:

When testing the simple demo of quay crane motion, v1.01 could just show the final state of the movement while v1.009 showcase the process of moving smoothly.

Relevant files as attached.
1stTryOut-p1.zip
You do not have the required permissions to view the files attached to this post.
suheti
 
Posts: 3
Joined: Fri Nov 12, 2010 9:12 pm

Re: Malfunctioning after upgraded

Postby sunzhuo » Sat Nov 13, 2010 12:17 am

I solved this problem. You can download 1.01 again.
User avatar
sunzhuo
Site Admin
 
Posts: 9
Joined: Mon Oct 06, 2008 11:30 pm

Re: Malfunctioning after upgraded

Postby suheti » Sun Nov 14, 2010 8:51 pm

New issues:

1. I used Sleep() function, but MicroCity does not show the intermediate condition and jumps to final result directly after the set duration. And it crushed once during my 4 attempts of testing of this script.

Files as attached.

2. The program is often not sensitive to mouse action.
You do not have the required permissions to view the files attached to this post.
suheti
 
Posts: 3
Joined: Fri Nov 12, 2010 9:12 pm

Re: Malfunctioning after upgraded

Postby sunzhuo » Sun Nov 14, 2010 11:18 pm

suheti wrote:New issues:

1. I used Sleep() function, but MicroCity does not show the intermediate condition and jumps to final result directly after the set duration. And it crushed once during my 4 attempts of testing of this script.


you should use SetPosition function to tell microcity the intermediate positions.

suheti wrote:2. The program is often not sensitive to mouse action.


fixed. Please download the latest version again.
User avatar
sunzhuo
Site Admin
 
Posts: 9
Joined: Mon Oct 06, 2008 11:30 pm


Return to Bug Report

Who is online

Users browsing this forum: No registered users and 1 guest

cron